Branch Coverage

blib/lib/AIX/LVM.pm
Criterion Covered Total %
branch 0 86 0.0


line true false branch
107 0 0 if $lsvg_error
141 0 0 unless $vg
142 0 0 exists $$self{$vg}{'prop'} ? :
150 0 0 unless $vg
151 0 0 unless $lv
152 0 0 exists $$self{$vg}{'lvol'}{$lv}{'prop'} ? :
160 0 0 unless $vg
161 0 0 unless $pv
162 0 0 exists $$self{$vg}{'pvol'}{$pv}{'prop'} ? :
170 0 0 unless $vg
171 0 0 unless $pv
172 0 0 exists $$self{$vg}{'pvol'}{$pv}{'PV_PP_CMD_OUT'} ? :
180 0 0 unless $vg
181 0 0 unless $pv
182 0 0 exists $$self{$vg}{'pvol'}{$pv}{'PV_LV_CMD_OUT'} ? :
190 0 0 unless $vg
191 0 0 unless $lv
192 0 0 exists $$self{$vg}{'lvol'}{$lv}{'LV_LOGICAL_CMD_OUT'} ? :
200 0 0 unless $vg
201 0 0 unless $lv
202 0 0 exists $$self{$vg}{'lvol'}{$lv}{'LV_MIRROR_CMD_OUT'} ? :
214 0 0 unless $lvg
217 0 0 if $lslv_error
220 0 0 if $lslv_l =~ /^(\S+)/
226 0 0 if $lspv_error
229 0 0 if $lspv_l =~ /^(\S+)/
235 0 0 if $prop_error
246 0 0 unless $lv
249 0 0 if $lslv_error
252 0 0 if $lspv_error
255 0 0 if $prop_error
266 0 0 unless $pv
269 0 0 if $lslv_error
272 0 0 if $lspv_error
275 0 0 if $lspp_error
278 0 0 if $prop_error
293 0 0 if ($prop =~ /\Q$defp\E([^\n]*?)($str|\n|$)/s) { }
313 0 0 unless my $pid = open3($writer_h, $reader_h, $error_h, @_)
320 0 0 if (fileno $fh == fileno $reader_h)
323 0 0 unless $ret
325 0 0 if (fileno $fh == fileno $error_h)
328 0 0 unless $ret
336 0 0 if $rc